Technical Help

Progressive's site is optimized for most modern browsers (desktop, tablet and mobile). Just make sure to:

  • Update your browser: We support the latest versions of Chrome, Firefox, Safari, Internet Explorer and Edge.
  • Enable Javascript: You'll need this to get your quote.
  • Accept cookies: You'll have a more personalized experience, and you can save certain information (like your policy ID) for future visits.
  • Download the latest Adobe Reader: You'll have an easier time getting forms and documents.

Updating your browser for security standards

Some older browsers may be using the Secure Sockets Layer (SSL) encryption protocol. SSL is an outdated protocol and no longer meets Progressive’s minimum required security standards. The latest encryption protocols are based on Transport Layer Security (TLS), with TLS v1.2 considered the most secure protocol supported by browsers today.

Progressive only supports browsers with TLS encryption enabled (v1.0, v1.1 or v1.2). That means if your browser does not support this encryption protocol, you will not be able to view or access Progressive.com. That’s why it is very important to make sure your browser supports TLS.

How to enable TLS

The easiest solution is to upgrade your browser. If you use the latest version of Chrome, Internet Explorer, Edge, Firefox, Safari or Opera you’ll already meet our security standards and won’t need to do anything else.

But, if you use Internet Explorer 8, 9 or 10 (and do not want to or can’t update to a newer browser) you may be able to follow these steps to update your browser security settings:

  1. Open the “Tools” menu in Internet Explorer. (Gear icon in the upper right corner of your window)
  2. Click “Internet Options” and then click the “Advanced” tab
  3. Scroll to the “Security” section and then check all boxes that mention “TLS” to enable TLS capability

Log In

Welcome!

Show
Need help logging in?

New user? Register for an account